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Change Summary
Motion Architect User Guide

Revision C

The following is a summary of the primary technical changes to this user guide since the last version was released.  This
user guide, p/n 88-013056-01C (released in August 1994), supersedes 88-013056-01B.

Topic Description

Add-on Utilities Servo Tuner™:  References to the Servo Tuner option for Motion Architect have removed to the new Servo Tuner User
Guide (p/n 88-014249-01).

CompuCAM is a new add-on module to Motion Architect (it can also be launched separately from Motion Architect).
CompuCAM allows you to translate DXF, HP-GL, and G-Code files into 6000 Series Language motion programs.

After add-on utilities are installed, they can be launched from the Utilities menu.
To order CompuCAM or Servo Tuner, contact your local Automation Technology Center.

Installation The procedure (setup utility) for installing Motion Architect has been changed.

DLL
(dynamic link
library)

Refer to the 6000 Series Programmer's Guide for instructions on using Compumotor's DLLs.

• WIN6400.DLL provides communication and fast status services for all 6000 Series bus-based products (not just the
AT6400). Function prototypes, type definitions, and error conditions can be found in WIN6400.H.

• Functions added:  Is controller ready; Timeout; Delay; Get extend fast status; and Send file.

New Products
Supported

Motion Architect now supports these 6000 Series products, as shown in the product selection dialog box:
AT6400-AUX1 AT6250 6270
AT6400-AUX2 AT6450 APEX615n Series
6200 6250 ZETA6104

Panel Module
Enhancements

• Following motion (master cycle number, master cycle position, master velocity, and net position shift) and Following
status (TFS status report) may be displayed.

• Status of the ANI inputs (servos with ANI option) may be displayed—see “Hi-Res Analog Inputs”.

• When you launch the Panel module, the controller is automatically “connected” (communication is established).  When
you close the Panel module, the controller is automatically disconnected.  The changes you make under the Settings
menu are automatically saved for subsequent Panel sessions.

• NOTE:  The Panel module is considered a “test panel”, not an “opera�tor panel”.

On-Line Reference
Guides

• The on-line 6000 Series Software Reference Guide (see 6000 Software Reference) has been updated.  Refer to the
Help menu.

• The on-line 6000 Following User Guide (see 6000 Following Reference) has been added.  Following instructions and
Following-specific command descriptions are found in this utility.  Refer to the Help menu.

Editor Module
Enhancements

• A toolbar has been added to provide easy access to common functions:
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• The View menu allows you to display or hide the toolbox and the status bar.  You can also customize the fonts and colors
in the editor window.

• “Navigate” and “Search” have been removed from the menu header.  Refer to the list of keystroke shortcuts on page 12.

• Editor now supports 255 levels of “Undo”.  “Redo” reverses the previous “Undo”.

• Print Preview is now supported (see File menu).

Terminal Module
Enhancements

• Same toolbar and View enhancements as noted above for the Editor.

• Now you can paste code from the clipboard into the active Terminal window, where the code is immediately executed by
the controller.

• When you launch the Terminal module, the controller is automatically “connected” (communication is established).
When you close the Terminal module, the controller is automatically disconnected.  The changes you make under the
Settings menu are automatically saved for subsequent Terminal sessions.

• Print Preview is now supported (see File menu).
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W  E  L  C  O  M  E

Introducing Motion Architect®

Welcome to Motion Architect, a Microsoft® Windows™ based application
development system to help you design, develop and debug programs for the
entire 6000 Series motion controller family.

The heart of Motion Architect is the Shell, which provides an integrated
environment to launch the following modules:

• System Configurator and Code Generator (Setup):  Automatically generate
controller code of basic system set-up parameters (I/O definitions, encoder
operations, drive setup, etc.), based on answers you give to dialog boxes.

• Program Editor (Editor):  Create blocks or lines of 6000 Series controller code,
or copy portions of code from a previous file.  You can save Editor files for
later use in a high-level program (e.g., BASIC, C, etc.), or in the Terminal or
Panel modules.

• Terminal Emulator (Terminal):  Communicating directly with the 6000 Series
product, the terminal emulator allows you to type in and execute controller
code and transfer code files to and from the controller.  Owners of 6000
Series bus-based controllers can transfer (download) the soft operating
system.

• Test Panel and Program Tester (Panel):  Create your own test panel to exercise
your programs and check the activity of I/O, motion, system status
indicators, timers and counters, and communications interface.

Help Utilities  ☞ In addition to the functions of the above modules, Motion Architect gives you
these on-line resources (see Help pull-down menu):

• Context-Sensitive Help:  Access via the Help pull-down menu, the Help buttons
in the dialog boxes, or by pressing the F1 key at any time.  This resource
provides comprehensive help information about the modules.

• On-Line User Guide: 6000 Series Software Reference

Optional Modules  ☞ The modules listed below are sold separately as add-on utilities to Motion
Architect.  After they are installed, you can access them from the Utilities
menu.  To purchase one of these options, contact your local Automation
Technology Center or distributor.

• Servo Tuner™ (Tuning and Data Gathering Tool):  Tune the drive(s) and the
controller and receive instant data feedback on customizable displays.

• CompuCAM™:  CAD-to-Motion (CAM) software allows you to translate DXF,
HP-GL, and G-Code files into 6000 Series Language motion programs.
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Before You Begin

User Guide Contents
• Chapter ➀—Motion Architect Basics:

- Motion Architect's on-line help and on-line reference guide utilities
- Standard file operations (New, Open, Save, Save As, and Exit)
- Managing multiple windows within one module
- Productivity tips

• Chapters ➁-➄:  These chapters describe how to use each of Motion Architect's
four main modules (Setup, Editor, Terminal, and Panel).  Information about the
optional add-on modules, such as Servo Tuner and CompuCAM, (see Utilities
menu) are provided in their respective user guides.

Who Should Use Motion Architect?
This software is intended to be used by software engineers or others
responsible for programming 6000 Series products for motion control
applications.

Windows™ Operating System Experience
To use Motion Architect most effectively, you should be familiar with the
Windows operating environment.  If you are new to the Microsoft Windows
operating system, refer to your Microsoft Windows User's Guide to learn
about the basic skills you need to work with Windows-based applications—
such skills include:
• Mouse and keyboard techniques
• Standard file operations (opening, closing, saving, printing, etc.)
• Managing windows
• Using menus and dialog boxes

Hardware and Software Requirements
Motion Architect requires the resources listed below (this does not include
memory requirements for optional add-on modules).
• Microsoft® Windows™ release 3.1 or later
• At least 2 MB of RAM
• At least 3 MB of hard disk space

Make a Backup Copy

5-1/4" diskettes
may be requested

from your local
distributor.

Motion Architect is shipped on two 3-1/2" high-density diskettes.  Before you
install Motion Architect on your hard disk, make backup copies of each
diskette in your Motion Architect package (refer to your operating system
manual for instructions).  Label the diskettes identical to the originals.  After
you have made copies, store the originals in a safe place and use the copies
as working copies.

Install Motion Architect on Your Hard Disk

Step 1 Insert the Motion Architect diskette labeled Disk 1 with Setup into floppy disk
drive A.

Step 2 From the Program Manager, click File and choose Run. You can also do this
from the File Manager. When the dialog box appears, type a:setup. When the
Welcome screen appears, click Continue. After a short period, the registration
screen will appear.
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Step 3 In the Custom Installation dialog box, you can specify the location where you
want to install Motion Architect, and you can select only those parts of
Motion Architect you wish to install.

Unless otherwise specified with the Set Location option, Motion Architect will be
installed in the MA6000 sub-directory.

In the Installation Options area, select the parts of Motion Architect you wish
to install:

• Motion Architect Program installs the files necessary to run Motion Architect.
• Motion Architect Help installs the on-line help system for Motion Architect.
• SDK/VB Samples installs sample Microsoft C and Visual Basic source code that

you can use to create your own Windows motion application.

Also, in the Installation Options area, select one or more 6000 Series
products that you will be working with.

After you have made the appropriate selections, click Install. If you selected
Motion Architect Help, you will be prompted to insert “Disk 2” of the two Motion
Architect diskettes. If you selected a 6000 Series bus-based product to work
with, you will be prompted to insert the “DOS Support Disk” (the support disk
that ships with the product and contains the soft operating system).

Step 4 After the installation is complete, the Installation Complete dialog box
appears. At this point, you have the options of reading the README file,
running Motion Architect, or returning to Windows.

Launching Motion Architect
After the setup utility has finished installing Motion Architect, the following
program group (Motion Architect) will appear.

To launch Motion Architect, double-click on the Motion Architect icon.  The
Motion Architect welcome screen will appear.  Click the Okay button to
remove the screen.  After a few moments, the Shell window will be displayed.

Selecting a 6000 Series Product
Click Product on the Motion Architect shell menu bar and choose Selection.
When the dialog box appears, select the 6000 Series product you are using
and click Okay.  As an example, the dialog box below shows that the 6270 is
selected.  The product you select here will be automatically selected the next
time you launch Motion Architect.

OEM Products:
Type in the name of your
product in the “Other” field.
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Motion Architect Basics

Shell Window

When you launch Motion Architect, the first window you see (after the start-
up screen) is the Shell.  Consider this window home base, if you will, for using
Motion Architect.  From the Shell window, you can do the following:

• Click the Product menu to select, or change, the 6000 Series product for which
you are using Motion Architect (see Step ➈ in the installation procedure).

• Launch the four main modules of Motion Architect (Setup, Editor, Terminal, and
Panel).

• Launch optional add-on modules, such as Drive Tuner, Servo Tuner, or
CompuCAM (Utilities).

• Access the on-line help utilities (Help).

On-line Help (Help)

Menu varies by module

From the menu bar in the Shell or any module, you can access the on-line
help system by clicking on Help, or by pressing the F1 key when a menu item
is selected.  The Help pull-down menu items are briefly described below.

Tip ☞ Click on the underlined green words, known as jump words, to get information on a
specific topic.

• Help for help.  The same help resource for all modules, describes how to use
the on-line help system's features.

• Keys help.  Defines the short-cut (hot) keys you can use within a particular
module to help you select certain commands or menu items faster.

• Help index.  Provides information on how to use the particular module from
which you accessed the on-line help system.  The information is categorized by
the items that appear in the module's menu bar.
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• 6000 Commands.  Displays the Command Dialog Box, from which you can look
up commands, edit them, and insert them into an active program editor session
or terminal emulator session.  For more information, refer to Command Dialog
Box below.

• 6000 Software Reference.  Brings you directly to the Contents menu of the on-
line version of the 6000 Series Software Reference Guide.  This is a valuable
resource for detailed command descriptions and programming guidelines.

• 6000 Following Reference.  Brings you directly to the Contents menu of the on-
line version of the 6000 Series Following User Guide.

• About.  Displays revision and copyright information.

Help Window Buttons
The buttons under the menu bar allow you to navigate through the on-line
help system:

• Contents will display the table of contents for the help system.  Clicking on an
underlined green item will take you to a particular topic.

• Search will allow you to jump to topics based on a keyword search.

• Back will take you back to the previously selected topic.

• History shows a complete record of your movements through the on-line help
session.

• Glossary, not shown on some menu bars, provides definitions of commonly
used terms in the help system.

• << or >>, not shown on some menu bars, allows you to browse backward or
forward through a sequence of topics.

Command Dialog Box (6000 Commands)
Clicking on the 6000 Commands menu item launches a dialog box similar to
the one shown below (this dialog box can also be accessed in the Terminal
and Editor modules by selecting the  button on the toolbar).

Selecting a command category will fill the adjacent list box with commands
from that category.  Selecting a command from the command list box will fill
the edit box at the bottom of the dialog where further editing can be done.
Clicking on Paste will paste the command from the edit box to the Editor or
Terminal session you have open at the time (command is pasted at the
location of the cursor).
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Clicking on the Help button displays a detailed description of the command,
as provided in the 6000 Series Software Reference Guide (example
below).

Standard File Operations (File)

Menu varies by module

These five standard file operations are found under the File pull-down menu
in all four modules:

• New creates a new file.
• Open opens an existing file.
• Save updates the file currently open with the latest edits.
• Save As saves the file currently open as a separate file under a new name.
• Exit exits (closes) the module and any open files within that module.

The New and Save As file operations give you the flexibility of creating
multiple controller code files and test panel files to solve complex or
fluctuating applications.  For instance, if you want to test several different
system I/O configurations, you could create several system set-up controller
code files with the Setup module.  These files could later be edited in the
Editor module and tested with several versions of test panels created with the
Panel module.

Printing  ☞ In the Editor and Terminal modules, printing operations (Print, Print Preview,
and Print Setup) are included so you can print your controller code files.  In
the Terminal module, you can print only the contents (up to 1500 lines) of
the terminal emulator window.

Arranging Multiple Windows in the Same Module (Window)

In the Editor and Panel modules, you can work with multiple files or windows
open at one time (e.g., viewing multiple controller programs in the Editor
module, or viewing several status displays in the Panel module).  To help you
arrange these windows for easy viewing, use one of the window viewing
options under the Window menu bar item.

Tile Horizontally: Tile Vertically:



8 Motion Architect User Guide

Cascade:

Arrange (Arranging Icons of Minimized Windows):

If you minimized (reduced to the icon level—see below) some of the
windows/files within a module, you can arrange their icons neatly along the
bottom of the window by clicking on Arrange.  To view the minimized
window/file, simply double-click the icon.

Close All (Closing All Windows):

Chose Close All if you want to close all the windows/files within the module.
If you made changes to the open files, you will be prompted with the option to
save before closing.

Productivity Tips
• To help with the iterative process of creating and revising programs, open the

Editor and Terminal modules and resize the two windows so that they are side by
side on your screen.  This allows you to easily switch between creating and
editing programs in the Editor, and downloading programs and checking
responses and error messages in the Terminal.

• Using the keystroke shortcuts (hot keys) to select menu commands is faster than
if you use the mouse.  To learn these hot keys, read the Keys Help descriptions
under the Help menu in each module, or simply look through the pull-down
menus for the keystroke listed next to the menu item.

• Use the on-line help, as well as the on-line 600 Software Reference (see 6000
Software Reference under the Help menu):

• If you need to test several different system configurations, controller programs, or
test panels, you may want to save several versions of the files created in each
module.  For instance, if you want to test several different system I/O
configurations, you could create several system set-up controller code files with
the Setup module.  These files could later be edited in the Editor module and
tested with several versions of operator panels created with the Panel module.

• Avoid confusion when several windows are open at one time:
- Avoid having more windows open than you really need.
- Use the Tiling feature in the Editor module to arrange the windows for easy

access to other files you are using.
- Try resizing windows, especially on-line help and command reference

windows, to be less than full screen.
- If you are working in a module and you lose track of a file's window (e.g., lost

behind several others) or if you do not have a mouse, you can access the
desired window by selecting its name from the list at the bottom of the
Window pull-down menu.
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System Configuration  (Setup)

What is the Setup Module?

The Setup module takes much of the drudgery out of motion control
programming.  This module automatically generates configuration code in
response to your answers to a series of dialogs concerning I/O definitions,
encoder operations, homing operations, end-of-travel limits, drive setup,
joystick setup, execution modes, etc.

Establishing System Set-up Parameters (Configure)
Under the Configure pull-down menu are the configuration parameters to
consider for your application.  When you select one of these parameters, a
dialog box appears.  Below is an example of the encoder configuration dialog
box.  Note that as you complete the configuration of the parameters, a check
mark (✓) appears next to the menu item.  If you are not going to generate code
now, you can save these configuration parameters as a separate configuration
(.cfg) file; otherwise, it will automatically be saved along with the program (.prg)
file for the resultant code when you click the Generate menu (see below).
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Generating Controller Code For System Set-up Parameters (Generate)
After you finish answering the dialog boxes under the Configure menu, click
the Generate menu to view the resultant controller code.  A message box will
appear to let you know that code generation is complete—click OK.  After you
click OK, if you have not saved the configuration parameters established
under the Configure menu, a SAVE AS dialog box appears and prompts you
to save these parameters as a separate configuration (.cfg) file.  As the .cfg file
is saved, a program (.prg) file is automatically saved to store the newly
generated code.  You can later use this .prg file as a building block for a set-up
program.

You will find the code to be neatly formatted and fully documented (see
example below).

Controller set-up
code is automatically
generated, based on
your answers to the
configuration dialog

boxes.
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Program Editor  (Editor)

What is the Editor Module?

The Editor module is a tool you can use to create and edit controller
programs using the 6000 Series Programming Language.  You can then save
these programs as separate files for later use in high-level programs (e.g.,
BASIC, C, etc.), or in the Terminal and Panel modules.

Using the Editor Module

This section describes the functions of the Edit and View menu bar items.
The functions of File, Window, and Help are discussed in Chapter ➀, Motion
Architect Basics.

Printing Controller Code Program Files
The Editor allows you to print your controller code program files.  Refer to the printing
operation commands under the File pull-down menu.

Editing Your Controller Code (Edit)
Under the Edit pull-down menu are commands that help you edit the
contents of your motion programs:

• Undo:  Undo the last edit operation, including deleting text (up to 255
consecutive undo operations are possible).

• Redo:  Undo the last Undo operation (up to 255 operations).

• Cut:  Cut (remove) highlighted text and send to the clipboard to later paste
somewhere else in the same file or in another program file.  This function is
duplicated by the  button on the toolbar.

• Copy:  Copy highlighted text to the clipboard to later paste somewhere else in
the same file or in another program file, or in an active Terminal session.  This
function is duplicated by the  button on the toolbar.
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• Paste:  Paste text from the clipboard into any open program file.  This function
is duplicated by the  button on the toolbar.

• Delete:  Delete highlighted text.

• Find:  Search for a specified text string in the active program file.

• Find Next:  Repeat the last Find operation to find the same text string elsewhere
in the same program file.

• Replace:  Search the entire active program file (or just an area of highlighted
text) for a certain text string and replace it with a different text string.

• Select All:  Select all text in the active program file.

• Clear All:  Delete (clear) all text in the active program file.

Customizing the Display Window (View)
• Toolbar:  Display or hide the toolbar.
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• Status Bar:  Display or hide the status bar at the bottom of the window.

• Font:  Change the characteristics (type face, size, color, etc.) of the font
displayed in the window.

• Color:  Change the color of the display window.

NOTE:  The font and color changes are valid only for the active session and
cannot be saved.

Hot Keys (Keystroke Shortcuts)

Cursor Movement Keys Press To move the insertion point

Up Arrow Up one line

Down Arrow Down one line

Right Arrow Right one character

Left Arrow Left one character

Ctrl + Right Arrow Right one word

Ctrl + Left Arrow Left one word

Home To the beginning of the line

End To the end of the line

Page Up Up one screen

Page Down Down one screen

Ctrl + Home To the beginning of the program file

Ctrl + End To the end of the program file
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Editing Keys Press To

Backspace Delete one character to the left of the insertion point

Delete Delete one character to the right of the insertion point, or
delete the highlighted text

Ctrl + C, or Ctrl + Insert Copy the select text and place it onto the Clipboard

Ctrl + X, or Ctrl + Delete Delete the select text and place it onto the Clipboard

Ctrl + V, or SHIFT + Insert Paste from the Clipboard into the active window

Ctrl + Z, or Alt + Backspace Undo the last editing action (up to 255 levels of undo)

SHIFT + Ctrl + Z Undo the last Undo action (up to 255 levels)

Text Selection Keys Press To select or cancel selection of

SHIFT + Left or Right Arrow One character at a time to the left or right

SHIFT + Up or Down Arrow One line of text up or down

SHIFT + Page Up All text, one screen up

SHIFT + Page Down All text, one screen down

SHIFT + Home Text to the beginning of the line

SHIFT + End Text to the end of the line

Ctrl + SHIFT + Left Arrow The previous word

Ctrl + SHIFT + Right Arrow The next word

Ctrl + SHIFT + Home Text to the beginning of the program file

Ctrl + SHIFT + End Text to the end of the program file

What to do after Editing

After you have created or edited an controller code file in the Editor, you can
save it as a separate file.  This file can then be used in the following ways:

• Before running the program in an application, you can test-run the file from the
Panel module.

• From within the Editor module, you can open any program file and print its
contents.

• From within the Editor module, you can copy the contents (part or all) of the file
and then paste it into the Terminal module for immediate execution.

• Within the Terminal module, download the file that was created in the Editor
module to the 6000 Series product for immediate execution (see Chapter ➃).

• Use the file's controller code in a high-level program (e.g., BASIC, C, etc.).

Note to bus-based controller users:  Refer to the DOS Support Disk for sample
programs in C, QuickBasic, Pascal, and Assembly.
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Terminal Emulator  (Terminal)

What is the Terminal Module?

Communicating directly with the 6000 Series product, the Terminal module
allows you to type in and execute controller code and transfer code files to
and from the controller.  The code is based on the 6000 Series Programming
Language.  From the Terminal module, bus-based product owners can
transfer (download) the soft operating system.

Using the Terminal Module
This section describes the functions of the following Terminal module menu
bar items:  Edit, Settings, Transfers, and View.  The functions of File and
Help are discussed in Chapter ➀, Motion Architect Basics.

Printing Controller Code
The Editor allows you to print the contents (up to 1500 lines) of the terminal emulator window.
Refer to the printing operation commands under the File pull-down menu.

Editing Your Controller Code (Edit)
Under the Edit pull-down menu are commands that help you edit (on a line-
by-line basis) the contents of your motion programs:

• Copy:  Copy highlighted text to the clipboard to later paste it in the active
terminal emulator session or paste it in a program editor file.  This function is
duplicated by the  button on the toolbar.

• Paste:  Paste text from the clipboard into the active terminal emulator session.
When the text is pasted, it is immediately executed.  This function is
duplicated by the  button on the toolbar.

• Find:  Search for a specified text string in the active session.

• Find Next:  Repeat the last Find operation to find the text string elsewhere.

• Select All:  Select all text in the current terminal emulator session.

• Clear All:  Delete (clear) all text in the current terminal emulator session.

Tip ☞ You can save the contents of the active terminal emulator session to a “_____.ter” file
and then edit that file in the Editor module.
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Setting Up Communications with the 6000 Series Controller (Settings)
The changes you make to the communication settings will be used for all
subsequent Terminal sessions, until you change them again.

NOTE
You can change these settings only if the controller is disconnected.  This is evident if there
is no check mark (✓) next to Connect under the Transfers pull-down menu.
Bus Based Controllers:  The address and interrupt settings are essentially a verification
of the DIP switch settings on the controller card mounted in your PC-AT; they do not override
the DIP switches.  Refer to the controller's user guide for procedures to set the DIP switches.

• Board Address:  Use the dialog box to set the bus-based controller's board
address.  The default is 768 Decimal (300 Hexadecimal).

• PC-AT Interrupt:  Use the dialog box to set the PC-AT interrupt.  The default is
no interrupt.

• Serial Port:  If you are using a stand-alone 6000 Series controller, use the
dialog box to select a communications port.  The default is COM1.

Communicating with the 6000 Series Controller (Transfers)
Use the commands under the Transfers pull-down menu to communicate
with the 6000 Series controller (referred to as controller).
• Connect:  Click this menu item to connect (enable communication with) or

disconnect the controller.  A check mark (✓) appears to indicate successful
connection to the controller.  Once the controller is connected, the New and
Open file operations under the File pull-down menu are not allowed until the
controller is disconnected.  To disconnect, select this menu item again
(disconnection is verified when the check mark disappears).  Launching the
Terminal module automatically connects the controller, and exiting the Terminal
module automatically disconnects the controller.

• Send Operating System (bus-based controllers):  Click this menu item to send
the soft operating system (6000 Series Command Language) to the bus-based
controller.  (This is a prerequisite to connecting, programming, or
sending/receiving a motion program.)  A message box appears to indicate if this
operation was successful.  If you have problems downloading the operating system,
refer to the troubleshooting procedures in the bus-based controller's user guide.

• Send Motion Program:  Click this menu item to send a controller code program
(file from your hard drive) to the controller, where it is immediately executed.  A
message box appears to indicate if this operation was successful.

WARNING
Downloading a motion-based program file to the controller can cause motion.  Before
downloading the program file, make the necessary precautions to ensure the safe
operation of the equipment.  Failure to do so can result in damage to equipment and/or
serious injury to personnel.

• Receive Motion Program:  Click this menu item to receive (upload) a controller
code program residing in the controller's memory.  From the dialog box, click on
the program(s) you wish to upload and click Okay. When the Save As dialog
box appears, you can save the contents of the uploaded file under a new file
name or overwrite the contents of an existing file on your hard drive.
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Customizing the Display Window (View)
• Toolbar:  Display or hide the toolbar.
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• Status Bar:  Display or hide the status bar at the bottom of the window.

• Font:  Change the characteristics (size, type face, color, etc.) of the font
displayed in the window.

• Color:  Change the color of the display window.

NOTE:  The font and color changes are valid only for the active session and
cannot be saved.
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Test Panel  (Panel)

What is the Panel Module?

The Panel module allows you to test your controller programs with your own
test panel.  You can customize the panel with multiple windows (monitoring
controller output) and programmable buttons (for user input).

One or more windows can be opened to view the following controller
information:
• I/O (programmable I/O, analog I/O, limits)
• Motion (motor and encoder position, velocity)
• Status (axis, system, interrupt, user status, and Following)
• Misc. (timer and counter values)
• Communications interface

Four tiers of eight user-definable buttons are available that allow you to send
controller code fragments (up to 256 characters each) to a 6000 Series
product.

You can download controller programs to the 6000 Series product via the file-
transfer (Transfer) menu, and execute them using programmable buttons or
external I/O.

Additionally, you can create as many test panel configurations as you wish,
and save them as separate files.

The remainder of this chapter is divided into Creating Your Own Custom Test
Panel and Communicating with the 6000 Series Controller.  The functions of
menu bar items File, Window, and Help are discussed in Chapter ➀, Motion
Architect Basics.
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Creating Your Own Custom Test Panel

This section describes how to create a custom test panel of display windows
and user-defined buttons.

Setting Up Displays
The following is a typical procedure to create new display windows:

➀ Select the subject of the new display from the Display pull-down menu.  An
empty window appears, displaying a message like Display not defined.  Select
(I/O, Motion, Status, etc.) menu to define.  Notice that the menu bar changes to
include a pull-down menu item for the display subject (e.g., I/O, Motion, etc.)
and View.  Below is an example of the menu bar change after selecting New I/O
Display.

➀  From the Displays menu, select New I/O Display.

➁  New menu bar items appear.

➁ From the I/O, Motion, etc. pull-down menu, select what you want to display.

➂ Complete the dialog box.  Hint:  Using the tab and arrow keys may be the most
efficient means of navigating through the dialog boxes.  (If you need help, click
the Help button.)

➃ When you have completed the dialog box, click Okay.  The new window is
displayed with the parameters specified.

➄ From the View pull-down menu (Font..., Color..., and Grid...), tailor the
display's font, color, and grid as desired.

➅ Repeat steps ➀ through ➃ for the rest of the display windows you want in your
custom operator panel.

➆ From the Window pull-down menu, select the desired window tiling method.
Tiling is described in Chapter ➀, Motion Architect Basics.

The following is an example of a panel of display windows created to show
programmable inputs, programmable outputs, motor position, and axis
status.  Tile Horizontally is selected.
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Setting Up User-Defined Buttons
The following is a typical procedure to set up the buttons:

➀ Select Define Buttons from the Settings pull-down menu.  A dialog box is
displayed.

➁ In the Button Name column of the dialog box, type in the description for each
button.  Up to nine characters are allowed (at maximum window sizing).  If you
need more than eight buttons, select more levels from the Button Level area of
the dialog box.  To create a hot key for the button, place “&” before the desired
character in the button name (e.g., type “S&top” to get Stop).  Remember to
select Buttons Visible for each level (row) of buttons you wish to be displayed.

➂ In the Command column, type in the 6000 Series command(s) to be executed
when the corresponding button is selected.  To execute multiple commands with
one button, type in the commands and separate them with colons (refer to the
Index, Cut, and Retract button commands in the example below).

If you do not know the exact syntax, select the Commands button to access the
on-line command reference, the same on-line tool provided in the Editor and
Terminal modules.  When you select the Paste button from the command dialog
box, the command will be pasted in the command column field where the cursor
was last located.

Instead of 6000 Series commands, you can use a DOS prompt command.  Simply
type in “>” followed by the path to the executable file.

➃ Check to make sure you have defined the buttons with the desired name and
command.  The following is an example of a completed button definition dialog
box.

➄ Click the Okay button when you have completed the button definitions and
display options.  The eight-button row(s) will be displayed at the bottom of your
screen, beneath the display windows (see example below).

Selecting Show Buttons from the Settings pull-down menu toggles between
displaying and hiding the buttons.

If you are not using a mouse, you can access the buttons (if displayed) via
Goto Buttons under the Settings pull-down menu.  Use the tab key to move
from button to button, and the space bar to activate the button.
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Communicating with the 6000 Series Controller

This section describes how to set up communications (Settings) and perform
transfer operations (Transfers) between your custom test panel and the 6000
Series Controller (referred to as controller).

Setting Up Communications with the 6000 Series Controller (Settings)
The changes you make to the communication settings will be used for all
subsequent Panel sessions, until you change them again.

NOTE
You can change these settings only if the controller is disconnected.  This is evident if there
is no check mark (✓) next to Connect under the Transfers pull-down menu.
Bus Based Controllers:  The address and interrupt settings are essentially a verification
of the DIP switch settings on the controller card mounted in your PC-AT; they do not override
the DIP switches.  Refer to the controller's user guide for procedures to set the DIP switches.

• Board Address:  Use the dialog box to set the bus-based controller's board
address.  The default is 768 Decimal (300 Hexadecimal).

• PC-AT Interrupt:  Use the dialog box to set the PC-AT interrupt.  The default is
no interrupt.

• Serial Port:  If you are using a stand-alone 6000 Series controller, use the
dialog box to select a communications port.  The default is COM1.

Communicating with the 6000 Series Controller (Transfers)
Use the commands under the Transfers pull-down menu to communicate
with the controller.

• Connect:  Click this menu item to connect (enable communication with) or
disconnect the controller.  A check mark (✓) appears to indicate successful
connection to the controller.  Once the controller is connected, the New and
Open file operations under the File pull-down menu are not allowed until the
controller is disconnected.  To disconnect, simply select this menu item again
(disconnection is verified when the check mark disappears).  Launching the
Panel module automatically connects the controller, and exiting the Panel module
automatically disconnects the controller.

• Send Operating System (bus-based controllers):  Click this menu item to send
the soft operating system (6000 Series Command Language) to the bus-based
controller.  (This is a prerequisite to connecting, programming, or
sending/receiving a motion program.)  A message box appears to indicate if this
operation was successful.  If you have problems downloading the operating
system, refer to the troubleshooting procedures in bus-based controller's user
guide.

• Send Motion Program:  Click this menu item to send a controller code program
(file from your hard drive) to the controller, where it is immediately executed.  A
message box appears to indicate if this operation was successful.

WARNING
Downloading a motion-based program file to the controller can cause motion.  Before
downloading the program file, make the necessary precautions to ensure the safe
operation of the equipment.  Failure to do so can result in damage to equipment and/or
serious injury to personnel.
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Index

6000 Series Programming Language 11, 15

address, bus-based controller 16, 22

backup copy 2
bus-based controllers

address 16, 22
communicating with 16, 22
connecting 16, 22
interrupts 16, 22

buttons, defining & displaying (Panel module) 21

CAD-to-motion software (CompuCAM) 1
cascading windows 8
change summary i
COM port selection 16, 22
command descriptions

command dialog box 6
viewing 7

communicating with the controller 16, 22
CompuCAM™ 1
configuration

communication set up 16, 22
system set-up parameters 9

connecting to the controller 16, 22
controllers

bus-based, see bus-based controllers
serial, see serial controllers

copy or cut text to the clipboard 11
customizing the display window

Editor module 12
Panel module 20
Terminal module 17

downloading files to the controller 16, 22
downloading the operating system 16, 22

editing controller code 11
Editor Module 11
hot keys 13
in terminal emulator 15

find 12

hardware requirements 2
help (on-line help system) 5, 8
hot keys 8

Editor module 12

installation, Motion Architect 2
interrupts, bus-based controllers 16, 22
jump words 5

keystroke shortcuts 8
Editor module 12

Microsoft Windows experience 2
monitoring controller output 19

on-line command reference 6, 8
on-line Following reference 6
on-line help 5, 8
operating system, downloading 16, 22

options
CompuCAM 1
Servo Tuner 1

Panel Module, see test panel
paste commands to the editor window 6
paste controller code from the clipboard 12, 13, 15
printing controller code 11, 15

set up 7
product selection 3
productivity tips 8
program (controller code)

editing 11
printing the file 11, 15
programming experience required 2
sending and receiving 16, 22
set-up (configuration) program 10
using finished code files 13

redo 11

saving files 7
search, search and replace text 12, 15
search help topics 6
serial controllers

COM port 16, 22
communicating with 16, 22

Servo Tuner™ 1
set-up

product selection 3
set-up program 10
Setup Module 9
system operating parameters 9

shell 5
software reference, on-line 6, 8
software requirements 2

terminal emulation (Terminal Module) 15
test panel (Panel Module) 19

displays 20
user-defined buttons 21

text search 12, 15
text search and replace 12
text selection, hot keys 13
tiling Panel display windows 20
tiling windows 7
tips on productivity 8
toolbar 12, 17

undo 11
uploading programs from the controller 16
user-defined buttons, Panel Module 21
utilities

add-on modules 1
help, see help

windows, managing
arranging icons 8
avoiding confusion 8
cascading and tiling 8
closing 8
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