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Introducing CompuCAM 

Overview 
CompuCAM is a Microsoft Windows-based programming package that provides computer aided 
motion (CAM) support for the 6000 Series and 6K Series controllers. CompuCAM is a utility you 
can start from within Motion Architect or from the Start menu. (CompuCAM must be purchased 
separately. It does not come with Motion Architect.) 
Computer aided motion means that CompuCAM can import 2D geometry from the sources listed 
below. For a discussion of the import filters, see Appendix A. 
• CAD programs:  The DXF (Data Interchange File) file format, developed by AutoDesk 

Corporation for its AutoCAD program, is the standard for CAD file transfer with PC-based 
CAD systems. 

• Plotter files:  The HP-GL (Hewlett-Packard Graphics Language) is a motion control 
language developed by Hewlett-Packard Company for its line of plotters.  

• NC programs:  The G-Code language is a standard (EIA Standard RS-274-D) NC 
programming language for machine tool applications.  

After importing the geometry, you can use CompuCAM to assign motion and I/O attributes and 
then generate commented programming code compatible with all Compumotor 6000 Series or 6K 
Series multi-axis stepper and servo controllers. 
The resulting motion program can then be saved to disk and verified. The Motion Architect editor 
(Editor) can be used to further edit the generated 6000 or 6K code. Then using the terminal 
emulator (Terminal) or test panel (Panel) you can download CompuCAM's generated code the 
controller. 

User Interface 
CompuCAM provides a highly interactive graphical environment for developing a motion 
program. Although full keyboard support is available, a mouse is recommended for maximum 
proficiency. 
A two-paned window provides you with simultaneous views of the imported geometry and the 
generated 6000 or 6K code. At any time you can graphically correlate the geometry and the 
code. By selecting a segment in the geometry pane, CompuCAM highlights the corresponding 
code in the code pane and vice-versa. 
With the menu bar you can ascribe motion and I/O attributes to the imported geometry. You can 
also save your work, retrieve previous sessions, zoom/pan the geometry, and access the Help 
system. 
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Basic Operations 
CompuCAM automatically generates 6000 or 6K code for positioning applications. CompuCAM 
supports three basic positioning operations:  
• Point-to-Point Positioning:  Point-to-point positioning allows axes to reach their final 

destination without synchronizing with each other.  Rapid traverse and homing moves are 
typically point-to-point operations. 

• Multi-Axis Linear Interpolation:  Linear interpolation allows multiple axes to achieve linear 
(straight line) motion. All axes start, accelerate, decelerate and stop in a synchronized 
manner. Motion must stop between segments in a linked chain of linear-interpolated 
segments. 

• 2-Axis Contouring (Circular Interpolation):  Contouring allows two axes to achieve 
curvilinear motion. A contouring path consists of one or more connected line and arc 
segments. Motion will not stop between connected segments in a path, but motion will stop at 
the end of a path. 

CompuCAM allows motion paths to be ordered (1, 2, 3, etc.), defined (linear interpolation, 
contouring, path acceleration, path velocity, etc.) and vectored. Furthermore, operations such as 
turning on an output or waiting for an input can be specified at the endpoints of each motion path. 
 

Reference Documentation 
For more information about the 6000 language, see the 6000 Series Software Reference 
Guide, or the on-line command reference in Motion Architect. For additional information on the 
user features available with each 6000 Series controller, see the respective controller user guide. 
For more information about the 6K language, see the 6K Command Reference Guide, or the 
on-line command reference in Motion Planner. For additional information on the user features 
available with each 6K Series controller, see the respective controller user guide. 
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Installing CompuCAM 

Overview 
This section describes the installation process for CompuCAM. To use CompuCAM, you will 
need an IBM/compatible computer with the following: 
• Microsoft Windows 3.1, Windows 95, Windows 98, or Windows NT  
• Motion Architect 2.2 or later (must be installed before CompuCAM) 
 Or, Motion Planner 2.0 or later 
• VGA color monitor 
• At least 2MB of RAM 
• At least 1MB of hard disk space 
• A math coprocessor is highly recommended 

Installation Procedure 
Step 1 
If you have not already done so, install Motion Architect or Motion Planner. CompuCAM will not 
install unless Motion Architect is already installed. Refer to the Motion Architect User Guide for 
installation instructions. 

Step 2 
Insert the CompuCAM diskette labeled Disk 1 with Setup into the disk drive. 

Step 3 
For Windows 3.1 do the following: 
From the Program Manager, click File and click Run. You can also do this from the File 
Manager. 
When the dialog box appears, type a:setup and click OK 
When the Welcome screen appears, click Continue. After a short period, the registration screen 
will appear. 
For Windows 95/98/NT do the following: 
On the Start menu, click Run. 
When the dialog box appears, type a:setup and click OK 
When the Welcome screen appears, click Continue. After a short period, the registration screen 
will appear. 
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Step 4 
In the User Information dialog box, enter your name and company name. Then click Next. 
Step 5 
In the Setup Type dialog box, you can select the type of installation you want—choose from 
Typical, Compact, and Custom. If you choose Custom, you can select the parts of CompuCAM 
to install: 
• CompuCAM Program installs the files necessary to run CompuCAM. 
• CompuCAM Help installs the on-line help system for CompuCAM. 
• CompuCAM Examples installs sample geometry files that you can import into CompuCAM 

sessions. 
Under Destination Directory, you can specify the path where CompuCAM is installed. Unless 
you indicate a path, CompuCAM is installed to C:\CCAM. To select the installation path, click the 
Browse… button. 
After you have made the appropriate selections, click Next. You will be prompted to insert Disk 2 
that contains the specific geometry import filters (DXF, HP-GL , and G-Code ). 

Step 6 
After the installation is complete, the Setup Complete dialog box appears. You can choose to 
view the README file, run CompuCAM, or return to Windows. 

Launching CompuCAM 
Motion Architect 
After CompuCAM is installed on your hard drive, you can start the program from Motion Architect. 
• If you are using Motion Architect 2.1 or earlier, you can launch CompuCAM only from the 

program group created at installation.  
• If you are using Motion Architect 2.2 or later, you can launch CompuCAM from the Utilities 
menu.  
Motion Planner 
You cannot start CompuCAM from Motion Planner. But you can import the .prg file created in 
CompuCAM into Motion Planner.
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CompuCAM Menus 

Overview 
This section describes all of the menus and commands that comprise CompuCAM. 
 
 
 
 
 

Tool Bar 

Geometry pane Code pane 

Status Bar

Location of cross-hair 
in the Geometry pane Split bar 

Current line of code 

Total lines of code in 
current layer
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File Menu 

 

The File menu lets you initialize, save, retrieve, and quit 
CompuCAM sessions. 

 

New 
The New command initializes the CompuCAM database to the default settings, and clears the 
geometry and code panes. This command duplicates the  button on the toolbar. 

Open... 
The Open command lets you retrieve a previous CompuCAM session (*.cam file). This command 
duplicates the  button on the toolbar. 

 

Save 
The Save command lets you save the current CompuCAM session to a *.cam file. This command 
duplicates the  button on the toolbar. 
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Save As... 
The Save As command lets you save the current CompuCAM session to a different *.cam file.  

 

Exit 
The Exit command lets you quit the CompuCAM session. Before quitting the program, you are 
prompted to save your work. 
 
 

Defaults Menu 

 

The Defaults menu lets you determine the default behavior of the 
CompuCAM environment. If you are using CompuCAM for the first 
time, before importing the geometry you should check the default 
settings and make any necessary changes to meet your 
application's requirements. Subsequent sessions of CompuCAM will 
use the setup parameters you select under the Defaults menu. 
Note: If you change the defaults during a current session, you must 
import the current geometry again for the new defaults to take affect. 
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CAD Name... 
The CAD File Name dialog box prompts you for the path and file name of your CAD software 
package. Later, when you choose the Run CAD command under the Tools menu, CompuCAM 
uses this path and file name to find and run your CAD software package. 

 

Color Selection... 
The Color Selection dialog box lets you specify the colors used in the geometry and code 
panes. 
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Axis Selection... 
The Axis Selection dialog box lets you specify the default X/Y axes and the Z axis of the target 
product. In the geometry pane, the X axis is the horizontal axis and the Y axis is vertical axis. The 
Z axis is only for use with G-Code . 
 

 

Scaling... 
The Scaling dialog box lets you specify acceleration, velocity, and distance scale factors for XY 
path and Z axes (Z axis is for G-Code use only). The 6000 and 6K Series controllers perform 
scaling.  
As an example, suppose the drawing you are importing is scaled to inches and you are operating 
a stepper motion control system with a resolution of 25,000 steps/rev, and each motor is attached 
to a 5-pitch (5 turns per inch) leadscrew. The scale factors for this application are depicted below. 
 
Scaling for 6000 Series controllers  Scaling for 6K Series controllers 
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Default Motion... 
Use the Default Motion dialog box to specify the default motion parameters: 
• Default Positioning 
 - Point-to-Point: Point-to-point positioning allows axes to reach their final destination 

without regard to synchronization with each other.  Rapid traverse and homing moves 
are typical examples. 

 - Linear Interpolation: Linear interpolation allows multiple axes to achieve linear (straight 
line) motion. All axes start, accelerate, decelerate, and stop in a synchronized manner. 
Motion must stop between segments in a linked chain of linear interpolated segments. 
Linear interpolated profiles are executed with the GOL command.   

 - Contouring (circular interpolation): Contouring (circular interpolation) allows multiple 
axes to achieve curvilinear motion in two or three dimensions (X-Y plane or X-Y-Z plane). 
Contouring motion is executed in a "path", a continuous-motion compound profile 
comprising any combination of contiguous line and arc segments. All axes involved in a 
path start, accelerate, decelerate, and stop in a synchronized manner. Contouring paths 
are defined like programs (using DEF and END commands), but are compiled with the 
PCOMP command and executed with the PRUN command.   

• Default Profile 
 - Normal Profile...:  A normal profile is the profile for executing the path associated with the 

lines on the drawing. Specify velocity, acceleration, and deceleration for XY path axes and 
the Z axis (Z axis is G-Code only). 

 - Rapid Profile...:  A rapid profile is the profile for traversing between normal profile paths. 
Specify velocity, acceleration, and deceleration for XY path axes and the Z axis (Z axis is 
G-Code only). 

These motion parameters can also be configured on a path-by-path basis in the Edit Motion 
dialog box found in the Edit Paths dialog box under the Tools menu. While in the Edit Paths 
dialog box, you can select All in the Paths selector to override the Default Motion settings, but 
only for the current imported geometry. The Edit Paths dialog box also lets you change the Path 
Direction. 
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Default Operations... 
The Default Operations dialog box lets you specify default operations (execution of 6000 Series 
commands) that you want to occur at path endpoints. Each path operation text box can contain 
multiple commands separated by colons ( : ), limited to a maximum of 256 characters including 
the colons. 
• Start-path operation (for example, turning on a laser) 
• Stop-path operation (for example, turning off a laser) 

 

You can also configure the operations on a path-by-path basis from the Edit Paths dialog box. In 
the Edit Paths dialog box select the path you want to edit, and then click the Edit Operations 
button. For example, in the Edit Paths dialog box under Paths, you can select All to override the 
Default Operations settings, but only for the current imported geometry. 

Code Generation... 
The Code Generation dialog box lets you specify 6000 code generation characteristics. For the 
6K Series, the Code Generation dialog box does not provide a choice for code generation 
characteristics. 
Code Generation for 6000 Series controllers Code Generation for 6K Series controllers 

  
 
• Algorithms (not applicable to Point-to-Point or Linear Interpolation code): 

- Define, Run, Delete (6000 Series controllers only): Select this option to define, run, and 
delete the code for each path in sequential order throughout the selected layer of the 
geometry (i.e., path #1 is defined, run, and deleted before generating code for path #2). 
Using this method, only one path is allowed in the 6000 controller's memory at any given 
time. Typically, large CAD drawings will require this code generation method.  

- Define All, Run All (6000 and 6K Series controllers): Select this option to define all paths 
in the selected layer of the geometry at one time, and then run all paths. This option 
requires a larger portion of memory than the Define, Run, Delete option, since all paths 
reside in the controller's memory. The code for running all paths is not generated until you 
save all code to a *.prg file (see Save All Code under the Tools menu). 

• Generate Homing Code:  Selecting this box will insert homing code (homes all axes) at the 
beginning of the *.prg file when you save all the code related to the imported geometry (Save 
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All Code). The Using CompuCAM section below illustrates an example of the homing code 
as viewed in Motion Architect's Editor module.  

Tolerances... 
The Tolerances dialog box lets you specify tolerances required by CompuCAM's code generator. 
You can set the unit of measure for path radius, linear interpolation, and segment attach 
tolerances in the Scaling dialog box. 

 

• Path Radius tolerance (units):  Maximum allowable radius error when creating an arc. 
Exceeding this tolerance will cause an error when downloading the program to the 6000 
Series product. 

• Linear Interpolation (units):  Also known as the chord tolerance, it is the maximum allowed 
distance between the curve and any chord of the polygonal approximation. A smaller 
tolerance setting will allow a smoother curve by allowing more chords per degree of arc. 

• Segment Attach (units):  Maximum allowable distance between path segment endpoints. 
Exceeding this tolerance will force a path break between the segments, placing the 
subsequent segment into a different path. 

• Discontinuity Angle (degrees):  Maximum allowable angle between two path segments 
(see illustration below). Exceeding this tolerance will force a path break between the 
segments, placing the subsequent segment into a different path. This tolerance is especially 
useful in stepper systems, which are prone to stalling when attempting radical direction 
changes. 

 

 

 

45° 90° 
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Tools Menu 

 

The Tools menu lets you create motion from the imported 
geometry. The typical order of usage for DXF and HP-GL users is 
listed below.  
1. Run CAD (create drawing, save as DXF or HP-GL) 
2. Import Geometry 
3. Select DXF Layer (DXF only) 
4. Edit and order Paths 
5. Generate Code 
6. Repeat steps 3 - 5 for each DXF layer 
7. Order DXF layers (DXF only) 
8. Save All Code 
G-Code users will use only the Import Geometry and Save All Code 
commands. 

 

Run CAD 
The Run CAD command lets you run your CAD software package. When you choose the Run 
CAD command, CompuCAM will use the path and file name you specified earlier in the CAD File 
Name dialog box to find and run your CAD software package. Once a drawing has been created, 
it should be saved as a DXF file (*.dxf) or an HP-GL plot file (*.plt). Appendix A provides general 
tips for creating CAD drawings for use with CompuCAM. 

Import Geometry... 
The Import Geometry command displays a dialog box that lets you import geometry (DXF, HP-
GL, G-code) into CompuCAM. The geometry will appear in the geometry pane of CompuCAM. 
CAD packages typically do not save geometry in the order in which they were drawn. The path of 
geometry is an end-to-end chain of line and/or arc segments. Segments are considered 
connected if the segment attach tolerance and the discontinuity angle tolerance are not violated. 
The segment-attach and discontinuity-angle tolerances are set in the Tolerances dialog box 
under the Defaults menu. You can change the path direction on a path-by-path basis in the Edit 
Paths dialog box under the Tools menu.  
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Correlating Code and Geometry 

You can correlate the generated code and the imported geometry in several ways. Correlating 
the code and geometry is an easy way to step through the code and verify the path order.  

• Click the ";Run Path n" field in the code pane to highlight the associated path in the 
geometry pane. The arrow superimposed on the path indicates the Path Direction. 

• Click the path in the geometry pane to highlight the associated motion-related code in the 
code pane. 

• Double-click the ";Run Path n" field in the code pane to display the Edit Paths dialog 
box. 

• Double-click the path in the geometry pane to display the Edit Paths dialog box. 

• Click  (step down) in the toolbar to highlight the next path in the geometry (or select 
the Step Down command under the Tools menu). 

• Click (step up) in the toolbar to highlight the previous path in the geometry (or select 
the Step Up command under the Tools menu). 
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Select DXF Layer... 

 

The Select DXF Layer dialog box lets you select a 
layer of an imported CAD (DXF) drawing for display in 
the geometry pane. You can subsequently Generate 
Code for each layer of the CAD drawing. 

Edit Paths... 

 

The Edit Paths dialog box lets you order the paths (for 
code generation), define motion attributes and end-of-
path operations for each path, change the Path 
Direction, generate code, and correlate paths with the 
related geometry in the geometry pane.  
To order paths, select the path number with the mouse 
or UP/DOWN ARROW keys, and then click Move Up or 
Move Down to reposition the path in relation to the 
other paths.  

 
Correlating Code and Geometry 
Double-clicking a path either in the geometry pane or in the code pane (;Run Path n) will display 
the Edit Paths dialog box.  Also, clicking a path in the geometry pane will highlight the related 
path in the Edit Paths dialog box (and vice-versa). 
 

Path Direction 
Clicking the Change Direction button can change the direction of each path. To view the path's 
direction relative to the rest of the geometry, click the path in the geometry pane, or click the 
associated ";Run Path n" comment in the code pane, or click the path number in the Paths 
selector in the Edit Paths dialog box. The arrowhead superimposed on the highlighted path in 
the geometry pane indicates the direction of the path. 

Path Motion Attributes and Endpoint Operations 
Where the Default Motion and Default Operations dialog boxes let you define a default motion 
attribute and default end-of-path operations for all paths, the Edit Motion and Edit Operations 
dialog boxes let you define the attributes and operations for individual paths. 
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In the Edit Motion and Edit Operations dialog boxes, you can also define the attributes and 
operations for all paths. To do this, first select All in the Edit Paths dialog box. When you then 
define the motion attributes and end-of-path operations in the Edit Motion and Edit Operations 
dialog boxes, those changes are applied to all paths in the entire imported geometry.  

Note: This overrides, for the current imported geometry only, the default settings as 
defined in the Default Motion... and Default Operations... dialog boxes. 

 

 

Re-Generating the Code 
If you edit paths after having generated code, you will have to re-generate the code (Generate 
Code command) if you want to view the changes. 

Generate Code 
Use the Generate Code command to generate code for the currently selected layer that is 
displayed in the geometry pane. The code for each path is generated according to the order 
specified in the Edit Paths dialog box. The generated code appears in code pane. 

Order DXF Layers... 
The Order DXF Layers dialog box lets you sequentially order the layers of an imported CAD 
drawing. You can order the layers at any time after you Import Geometry and before you Save 
All Code. CompuCAM's code generator will obey this ordering when you save all code with the 
Save All Code command. 
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Save All Code... 
The Save All Code dialog box lets you save all the code generated in the current CompuCAM 
session to a program (.prg) file. For DXF users, the code for all layers is saved at one time. The 
order in which the code is saved is determined by the order established in the Order DXF Layers 
and Edit Paths dialog boxes.  

 

In addition to the geometry code, the program file contains all the set-up and homing code 
associated with the parameters established under the Defaults menu. 
After the program file is created, you can further edit it in Motion Architect or Motion Planner 
using the Program Editor. And once you download the program to your controller, you can 
execute the generated code using the Terminal Emulator. 
For more information about the Program Editor, Terminal Emulator, or downloading programs,  
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refer to the Motion Architect or Motion Planner on-line help or printed guides. 
 

WARNING! 
! 

 WARNING! 

 
Downloading the program file will cause motion. Before downloading the program file to the 6000 
or 6K Series controller, make the necessary precautions to ensure the safe operation of the 
equipment. Failure to do so can result in damage to equipment and/or serious injury to personnel. 
 

Step Down and Step Up 
• Select the Step Down command to highlight the next path in the geometry (for example, step 

from path #4 to path #5). You can also click  (step down) in the toolbar. 
 

• Select the Step Up command to highlight the previous path in the geometry (for example, 

step from path #4 to path #3). You can also click  (step up) in the toolbar. 

View Menu 

 

The View menu provides various options for viewing the imported 
geometry.  

 

Zoom In 
The Zoom In command doubles the size of the geometry view. 

Zoom Out 
The Zoom Out command reduces the current geometry view to half-size. 

Initial Size 
The Initial Size command restores the geometry view to its original viewing size at the time it 
was imported. 
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Show All 
The Show All command resizes the current geometry view so that it fits entirely inside the 
geometry pane. The aspect ratio of the geometry is maintained.  

Toolbar 
The Toolbar command lets you show or hide the toolbar. The toolbar button functions are as 
follows: 

 Same function as the New command under the File menu. 

 Same function as the Open... command under the File menu. 

  Same function as the Save command under the File menu. 

  Same function as the Step Down command under the Tools menu. 

  Same function as the Step Up command under the Tools menu. 

 Same function as the About CompuCAM command under the Help menu. 

  Point-and-click Help. Select this button and click an item in the CompuCAM window to 
find out more about how to use that item. 

Status Bar 
The Status Bar command lets you show or hide the status bar.  

Split 
The Split command lets you move the split bar with the LEFT or RIGHT ARROW keys (you can also 
drag the split bar using the mouse). For course adjustments, just press the LEFT or RIGHT ARROW 
keys. For fine adjustments, hold down the CTRL key while pressing the LEFT or RIGHT ARROW keys. 
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Help Menu 

 

The commands in the Help menu let you access the on-line help 
system, as well as verify the version number and registration 
information of the program. 

 

Index 
The Index command displays a list of Help topics.  

Using Help 
The Using Help command displays instructions on how to use help. 

About CompuCAM... 
The About CompuCAM command displays a dialog box showing the program version number, 
serial number, copyright notice, and the CompuCAM icon. 
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Using CompuCAM 

The following is a quick-start guide on how to use CompuCAM with the installed sample files.  

Step 1:  Import Geometry 
Import a sample geometry file into CompuCAM—On the Tools menu, click Import Geometry. 
You can then select one of the following sample files to import: 
• SAMPLE.DXF 
• SAMPLE.PLT 
• SAMPLE.G 

Step 2:  Generate Code (DXF and HP-GL only) 
On the Tools menu, click Generate Code. The generated code appears in the code pane.  

Step 3:  Save All Code 
On the Tools menu, dlick Save All Code. This saves your generated code to a program (.prg) 
file. 
After creating the program file, you can edit it in Motion Architect's Program Editor (Editor) 
module. One parameter you should edit is the PSET command value to establish the proper 
home location for your application (see illustration below). 
The illustration below shows an example of the program file as viewed in the Editor module. 
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In Motion Architect or Motion Planner, download the program file to the controller, and then use 
Terminal Editor to execute the generated code. 
For more information about the Terminal Emulator, or downloading programs, refer to the Motion 
Architect or Motion Planner on-line help or printed guides. 
 

WARNING! 
! 

 WARNING! 

 
Downloading the program file will cause motion. Before downloading the program file to the 6000 
or 6K Series controller, make the necessary precautions to ensure the safe operation of the 
equipment. Failure to do so can result in damage to equipment and/or serious injury to personnel. 
 

PSET command establishes 
home location 
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Appendix A: DXF & HP-GL Import Filters 

DXF Import Filter 
The DXF import filter accepts the following geometric entities: 
• Arcs 
• Circles 
• Lines  
• Polylines (for representing complex geometry such as ellipses, splines, & Bezier curves) 
• Solids 
• Traces 

The DXF filter will only import curve geometry and does not handle points, text, and blocks. 

HP-GL Import Filter 
The HP-GL import filter accepts the following subset of HP-GL: 
AA Arc Absolute 
AR Arc Relative 
CI Circle 
IP Input P1 and P2 
PA Plot Absolute 
PD Pen Down 
PR Plot Relative 
PU Pen Up 
SC Scale 
 
The HP-GL import filter does not handle any of the instructions from the polygon group, the line 
and fill attributes group, the character group, nor any of the advanced extensions. 
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Tips for CAD Development 
Use the following general guidelines when creating CAD files for use with CompuCAM.  
• Use the CAD program's Attach tool to precisely connect line and arc segments. 
• Use the CAD program's Ungroup tool to break apart grouped geometry. 
• Delete unneeded layers. 
 

Homing Location 
Most applications require a homing location that is removed from the geometry area. To ensure a 
proper homing location, you should edit the PSET command value in the final program file. After 
completing the CompuCAM session, select the Save All Code—CompuCAM then creates the 
program (.prg) file.  To edit the program file, refer to Step 3 in the chapter above entitled Using 
CompuCAM. 
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Appendix B: G-Code Import Filter 
The G-Code import filter accepts the following subset of EIA RS-274-D G-Codes: 
F Codes: Feedrate  
G Codes: G00 Rapid traverse positioning mode (Default) 
  G01 Linear interpolation mode 
  G02 Clockwise contouring mode 
  G03 Counterclockwise contouring mode 
  G04 Time Delay 
  G28 Move to home switch input 
  G61 Turn off continuous path motion 
  G64 Turn on continuous path motion (Default) 
  G79 Execute a subroutine before each subsequent move 
  G80 Cancel G79 mode (Default) 
  G90 Absolute positioning mode (Default) 
  G91 Incremental positioning mode 
  G92 Set current position 
H Codes: Allow you to add an offset to each axis (user customizable) 
I Codes: First axis incremental distance to center point 
J Codes: Second axis incremental distance to center point 
L Codes: Number of repeats for a subroutine call 
M Codes: M01 End of program 
  M06 Same as M01 
  M98 Execute a gosub 
  M99 Return from a subroutine 
  NOTE:  M02 - M05 and M07 - M97 are user customizable 
N Codes: Optional line number 
O Codes: Begin definition of a subroutine 
P Codes: Time delay or subroutine definition number 
R Codes: Radius of an arc 
X Codes: Commands a move on the X-axis 
Y Codes: Commands a move on the Y-axis 
Z Codes: Commands a move on the Z-axis 
"  " Codes: All characters between quotes are sent directly to 6000 product 
(  ) Codes: All characters between parentheses are ignored 
 
The G-Code filter will import geometry from NC programs that do interpolated motion, as well as 
XY motion, with an unrelated Z motion. The XYZ interpolated motion includes linear XYZ motion 
and arcs in the XY plane. It does not include arcs in the XZ or YZ planes. 
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